p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de coreshop/core-shop

Vulnérabilité publiée pour coreshop/core-shop au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2026-41249

    Élevée · CVSS 8.2EPSS 0,55%Aucun correctif publié

    CoreShop Vulnerable to Remote Code Execution (RCE) via Insecure `pull_request_target` Configuration

    CoreShop is a Pimcore enhanced eCommerce solution. In versions 5.0.1 through 5.1.0-beta.1,, the GitHub Actions workflow (`.github/workflows/static.yml`) uses the `pull_request_target` trigger but dangerously checks out the unverified code from the pull request head (`ref: ${{ github.event.pull_request.head.ref }}`). Subsequently, it executes a script (`bin/console`) from this untrusted checkout. This allows any external attacker to achieve Remote Code Execution (RCE) on the GitHub Actions runner simply by submitting a malicious Pull Request. Also known as a "Pwn Request" vulnerability. As of time of publication, `pull_request_target` is still

    Publication Mise à jour
  2. CVE-2026-23959

    Moyenne · CVSS 6.9EPSS 0,42%Correctif disponible

    CoreShop Vulnerable to SQL Injection via Admin customer-company-modifier

    CoreShop is a Pimcore enhanced eCommerce solution. An error-based SQL Injection vulnerability was identified in versions prior to 4.1.9 in the `CustomerTransformerController` within the CoreShop admin panel. The affected endpoint improperly interpolates user-supplied input into a SQL query, leading to database error disclosure and potential data extraction. Version 4.1.9 fixes the issue.

    • Mettez à jour vers 4.1.9
    Publication Mise à jour
  3. CVE-2026-22242

    Moyenne · CVSS 4.9EPSS 0,43%Correctif disponible

    CoreShop Vulnerable to SQL Injection via Admin Reports

    CoreShop is a Pimcore enhanced eCommerce solution. Prior to version 4.1.8, a blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. This issue has been patched in version 4.1.8.

    • Mettez à jour vers 4.1.8
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →