p PatchFirst

PatchFirst · Latest vulnerabilities

coreshop/core-shop vulnerabilities

Vulnerabilities published for coreshop/core-shop in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-41249

    High · CVSS 8.2EPSS 0.55%No fix published

    CoreShop Vulnerable to Remote Code Execution (RCE) via Insecure `pull_request_target` Configuration

    CoreShop is a Pimcore enhanced eCommerce solution. In versions 5.0.1 through 5.1.0-beta.1,, the GitHub Actions workflow (`.github/workflows/static.yml`) uses the `pull_request_target` trigger but dangerously checks out the unverified code from the pull request head (`ref: ${{ github.event.pull_request.head.ref }}`). Subsequently, it executes a script (`bin/console`) from this untrusted checkout. This allows any external attacker to achieve Remote Code Execution (RCE) on the GitHub Actions runner simply by submitting a malicious Pull Request. Also known as a "Pwn Request" vulnerability. As of time of publication, `pull_request_target` is still

    Published Updated
  2. CVE-2026-23959

    Medium · CVSS 6.9EPSS 0.42%Fix available

    CoreShop Vulnerable to SQL Injection via Admin customer-company-modifier

    CoreShop is a Pimcore enhanced eCommerce solution. An error-based SQL Injection vulnerability was identified in versions prior to 4.1.9 in the `CustomerTransformerController` within the CoreShop admin panel. The affected endpoint improperly interpolates user-supplied input into a SQL query, leading to database error disclosure and potential data extraction. Version 4.1.9 fixes the issue.

    • Update to 4.1.9
    Published Updated
  3. CVE-2026-22242

    Medium · CVSS 4.9EPSS 0.43%Fix available

    CoreShop Vulnerable to SQL Injection via Admin Reports

    CoreShop is a Pimcore enhanced eCommerce solution. Prior to version 4.1.8, a blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. This issue has been patched in version 4.1.8.

    • Update to 4.1.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →