p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de alerta-server

Vulnérabilité publiée pour alerta-server au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-34400

    Moyenne · CVSS 6.9EPSS 0,53%Correctif disponible

    alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API

    Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.

    • Mettez à jour vers 9.1.0
    Publication Mise à jour
  2. CVE-2020-26214

    Critique · CVSS 9.1EPSS 65,93%Code d’exploitation publicCorrectif disponible

    LDAP authentication bypass in Alerta

    In Alerta before version 8.1.0, users may be able to bypass LDAP authentication if they provide an empty password when Alerta server is configure to use LDAP as the authorization provider. Only deployments where LDAP servers are configured to allow unauthenticated authentication mechanism for anonymous authorization are affected. A fix has been implemented in version 8.1.0 that returns HTTP 401 Unauthorized response for any authentication attempts where the password field is empty. As a workaround LDAP administrators can disallow unauthenticated bind requests by clients.

    • Mettez à jour vers 7.5.7
    • Mettez à jour vers 8.1.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →