p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache-airflow-providers-ftp

Vulnérabilité publiée pour apache-airflow-providers-ftp au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-49486

    Élevée · CVSS 7.5EPSS 0,44%Correctif disponible

    Apache Airflow FTP provider: FTP Provider does not protect FTPS data channel (missing PROT_P)

    The Apache Airflow FTP provider's `FTPSHook.get_conn()` created an `ftplib.FTP_TLS` connection but never called `prot_p()`, so although the control channel was TLS-protected the data channel was transmitted in cleartext. Any deployment using `FTPSHook` or `FTPSFileTransmitOperator` to move files over FTPS exposed file contents and credentials-in-transit to a network attacker able to observe the data connection. Upgrade apache-airflow-providers-ftp to `3.15.1` or later, which issues `PROT P` to encrypt the data channel.

    • Mettez à jour vers 3.15.1
    Publication Mise à jour
  2. CVE-2024-29733

    Faible · CVSS 2.7EPSS 0,63%Correctif disponible

    Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context

    Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

    • Mettez à jour vers 3.7.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →