p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache-airflow-providers-mysql

Vulnérabilité publiée pour apache-airflow-providers-mysql au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2025-27018

    Moyenne · CVSS 6.3EPSS 0,91%Correctif disponible

    Apache Airflow MySQL Provider: SQL injection in MySQL provider core function

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.

    • Mettez à jour vers 6.2.0
    Publication Mise à jour
  2. CVE-2023-22884

    Critique · CVSS 9.8EPSS 11,08%Correctif disponible

    Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow

    Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.

    • Mettez à jour vers 4.0.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →