p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de fastapi

Vulnérabilité publiée pour fastapi au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2024-24762

    Élevée · CVSS 7.5EPSS 1,52%Correctif disponible

    python-multipart vulnerable to content-type header Regular expression Denial of Service

    `python-multipart` is a streaming multipart parser for Python. When using form data, `python-multipart` uses a Regular Expression to parse the HTTP `Content-Type` header, including options. An attacker could send a custom-made `Content-Type` option that is very difficult for the RegEx to process, consuming CPU resources and stalling indefinitely (minutes or more) while holding the main event loop. This means that process can't handle any more requests, leading to regular expression denial of service. This vulnerability has been patched in version 0.0.7.

    • Mettez à jour vers 0.109.1
    Publication Mise à jour
  2. CVE-2021-32677

    Élevée · CVSS 8.2EPSS 0,72%Correctif disponible

    Cross-Site Request Forgery (CSRF) in FastAPI

    FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). A request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. Requests with co

    • Mettez à jour vers 0.65.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →