p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in fastapi

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für fastapi: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2024-24762

    Hoch · CVSS 7.5EPSS 1,52%Korrektur verfügbar

    python-multipart vulnerable to content-type header Regular expression Denial of Service

    `python-multipart` is a streaming multipart parser for Python. When using form data, `python-multipart` uses a Regular Expression to parse the HTTP `Content-Type` header, including options. An attacker could send a custom-made `Content-Type` option that is very difficult for the RegEx to process, consuming CPU resources and stalling indefinitely (minutes or more) while holding the main event loop. This means that process can't handle any more requests, leading to regular expression denial of service. This vulnerability has been patched in version 0.0.7.

    • Auf 0.109.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-32677

    Hoch · CVSS 8.2EPSS 0,72%Korrektur verfügbar

    Cross-Site Request Forgery (CSRF) in FastAPI

    FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). A request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. Requests with co

    • Auf 0.65.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →