SUSE-SU-2023:2077-1
SUSE-SU-2023:2077-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for webkit2gtk3 fixes the following issues: Update to version 2.38.6 (bsc#1210731): - CVE-2022-0108: Fixed information leak. - CVE-2022-32885: Fixed arbitrary code execution. - CVE-2023-25358: Fixed use-after-free vulnerability in WebCore::RenderLayer. - CVE-2023-27932: Fixed Same Origin Policy bypass. - CVE-2023-27954: Fixed sensitive user information tracking. - CVE-2023-28205: Fixed arbitrary code execution (bsc#1210295). Already fixed in version 2.38.5: - CVE-2022-32886, CVE-2022-32912, CVE-2023-25360, CVE-2023-25361, CVE-2023-25362, CVE-2023-25363.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise Real Time 15 SP3
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Manager Proxy 4.2
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Manager Server 4.2
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Enterprise Storage 7
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 SUSE:Enterprise Storage 7.1
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
webkit2gtk3 openSUSE:Leap 15.4
- Plages de versions concernées
- ECOSYSTEM: < 2.38.6-150200.72.1
Mettez à jour vers 2.38.6-150200.72.1
Sources originales
- https://www.suse.com/support/update/announcement/2023/suse-su-20232077-1/
- https://bugzilla.suse.com/1210295
- https://bugzilla.suse.com/1210731
- https://www.suse.com/security/cve/CVE-2022-0108
- https://www.suse.com/security/cve/CVE-2022-32885
- https://www.suse.com/security/cve/CVE-2022-32886
- https://www.suse.com/security/cve/CVE-2022-32912
- https://www.suse.com/security/cve/CVE-2023-25358
- https://www.suse.com/security/cve/CVE-2023-25360
- https://www.suse.com/security/cve/CVE-2023-25361
- https://www.suse.com/security/cve/CVE-2023-25362
- https://www.suse.com/security/cve/CVE-2023-25363
- https://www.suse.com/security/cve/CVE-2023-27932
- https://www.suse.com/security/cve/CVE-2023-27954
- https://www.suse.com/security/cve/CVE-2023-28205
- https://osv.dev/vulnerability/SUSE-SU-2023:2077-1