p PatchFirst

SUSE-SU-2023:3943-1

SUSE-SU-2023:3943-1 · Security update for python311

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

This update for python311 fixes the following issues: Update to 3.11.5. - CVE-2023-40217: Fixed TLS handshake bypass on closed sockets (bsc#1214692). - CVE-2023-41105: Fixed input truncation on null bytes in os.path.normpath (bsc#1214693).

Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Mettez à jour vers 3.11.5-150400.9.20.1

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311-documentation SUSE:Linux Enterprise Module for Python 3 15 SP4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Mettez à jour vers 3.11.5-150400.9.20.1

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311-documentation SUSE:Linux Enterprise Module for Python 3 15 SP5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311 openSUSE:Leap 15.4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Mettez à jour vers 3.11.5-150400.9.20.1

  • python311-core openSUSE:Leap 15.4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311-documentation openSUSE:Leap 15.4

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311 openSUSE:Leap 15.5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Mettez à jour vers 3.11.5-150400.9.20.1

  • python311-core openSUSE:Leap 15.5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

  • python311-documentation openSUSE:Leap 15.5

    Plages de versions concernées
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Mettez à jour vers 3.11.5-150400.9.20.2

Sources originales

Vérifiez votre serveur →