p PatchFirst

SUSE-SU-2023:3943-1

SUSE-SU-2023:3943-1 · Security update for python311

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for python311 fixes the following issues: Update to 3.11.5. - CVE-2023-40217: Fixed TLS handshake bypass on closed sockets (bsc#1214692). - CVE-2023-41105: Fixed input truncation on null bytes in os.path.normpath (bsc#1214693).

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Auf 3.11.5-150400.9.20.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311-documentation SUSE:Linux Enterprise Module for Python 3 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Auf 3.11.5-150400.9.20.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311-documentation SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Auf 3.11.5-150400.9.20.1 aktualisieren

  • python311-core openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311-documentation openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.1

    Auf 3.11.5-150400.9.20.1 aktualisieren

  • python311-core openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

  • python311-documentation openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.5-150400.9.20.2

    Auf 3.11.5-150400.9.20.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →