SUSE-SU-2024:1270-1
SUSE-SU-2024:1270-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for webkit2gtk3 fixes the following issues: - CVE-2024-23252: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2024-23254: Fixed possible audio data exilftration cross-origin via malicious website (bsc#1222010). - CVE-2024-23263: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2024-23280: Fixed possible user fingeprint via malicious crafted web content (bsc#1222010). - CVE-2024-23284: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2023-42950: Fixed arbitrary code execution via crafted web content (bsc#1222010). - CVE-2023-42956: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2023-42843: Fixed address bar spoofing via malicious website (bsc#1222010). Other fixes: - Update to version 2.44.0 (bsc#1222010): + Make the DOM accessibility tree reachable from UI process with GTK4. + Removed the X11 and WPE renderers in favor of DMA-BUF. + Improved vblank synchronization when rendering. + Removed key event reinjection in GTK4 to make keyboard shortcuts work in web sites. + Fix gamepads detection by correctly handling focused window in GTK4.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Manager Proxy 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 SUSE:Manager Server 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
webkit2gtk4 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.44.0-150400.4.78.1
Mettez à jour vers 2.44.0-150400.4.78.1
Sources originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20241270-1/
- https://bugzilla.suse.com/1222010
- https://www.suse.com/security/cve/CVE-2023-42843
- https://www.suse.com/security/cve/CVE-2023-42950
- https://www.suse.com/security/cve/CVE-2023-42956
- https://www.suse.com/security/cve/CVE-2024-23252
- https://www.suse.com/security/cve/CVE-2024-23254
- https://www.suse.com/security/cve/CVE-2024-23263
- https://www.suse.com/security/cve/CVE-2024-23280
- https://www.suse.com/security/cve/CVE-2024-23284
- https://osv.dev/vulnerability/SUSE-SU-2024:1270-1