p PatchFirst

SUSE-SU-2024:1270-1

SUSE-SU-2024:1270-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: - CVE-2024-23252: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2024-23254: Fixed possible audio data exilftration cross-origin via malicious website (bsc#1222010). - CVE-2024-23263: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2024-23280: Fixed possible user fingeprint via malicious crafted web content (bsc#1222010). - CVE-2024-23284: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2023-42950: Fixed arbitrary code execution via crafted web content (bsc#1222010). - CVE-2023-42956: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2023-42843: Fixed address bar spoofing via malicious website (bsc#1222010). Other fixes: - Update to version 2.44.0 (bsc#1222010): + Make the DOM accessibility tree reachable from UI process with GTK4. + Removed the X11 and WPE renderers in favor of DMA-BUF. + Improved vblank synchronization when rendering. + Removed key event reinjection in GTK4 to make keyboard shortcuts work in web sites. + Fix gamepads detection by correctly handling focused window in GTK4.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Proxy 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Server 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.0-150400.4.78.1

    Auf 2.44.0-150400.4.78.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →