SUSE-SU-2024:4084-1
SUSE-SU-2024:4084-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for webkit2gtk3 fixes the following issues: Update to version 2.46.3 (bsc#1232747): - CVE-2024-44244: Processing maliciously crafted web content may lead to an unexpected process crash. - CVE-2024-44296: Processing maliciously crafted web content may prevent Content Security Policy from being enforced. - CVE-2024-40866: Visiting a malicious website may lead to address bar spoofing. New references to version 2.46.0 (boo#1231039): - CVE-2024-44187: A cross- origin issue existed with “iframe” elements. This was addressed with improved tracking of security origins. - CVE-2024-44185: Processing maliciously crafted web content may lead to an unexpected process crash.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk3 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
webkit2gtk4 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150600.12.16.1
Mettez à jour vers 2.46.3-150600.12.16.1
Sources originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20244084-1/
- https://bugzilla.suse.com/1231039
- https://bugzilla.suse.com/1232747
- https://www.suse.com/security/cve/CVE-2024-40866
- https://www.suse.com/security/cve/CVE-2024-44185
- https://www.suse.com/security/cve/CVE-2024-44187
- https://www.suse.com/security/cve/CVE-2024-44244
- https://www.suse.com/security/cve/CVE-2024-44296
- https://osv.dev/vulnerability/SUSE-SU-2024:4084-1