p PatchFirst

SUSE-SU-2024:4084-1

SUSE-SU-2024:4084-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: Update to version 2.46.3 (bsc#1232747): - CVE-2024-44244: Processing maliciously crafted web content may lead to an unexpected process crash. - CVE-2024-44296: Processing maliciously crafted web content may prevent Content Security Policy from being enforced. - CVE-2024-40866: Visiting a malicious website may lead to address bar spoofing. New references to version 2.46.0 (boo#1231039): - CVE-2024-44187: A cross- origin issue existed with “iframe” elements. This was addressed with improved tracking of security origins. - CVE-2024-44185: Processing maliciously crafted web content may lead to an unexpected process crash.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150600.12.16.1

    Auf 2.46.3-150600.12.16.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →