SUSE-SU-2024:4117-1
SUSE-SU-2024:4117-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for webkit2gtk3 fixes the following issues: Update to version 2.46.3 (bsc#1232747), including fixes for: - CVE-2024-44308: Fixed arbitrary code execution by not allocating DFG register after a slow path (bsc#1233631). - CVE-2024-44309: Fixed a data isolation bypass vulnerability (bsc#1233632). - CVE-2024-44244: Processing maliciously crafted web content may lead to an unexpected process crash. - CVE-2024-44296: Processing maliciously crafted web content may prevent Content Security Policy from being enforced.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Manager Proxy 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 SUSE:Manager Server 4.3
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
webkit2gtk4 openSUSE:Leap 15.5
- Plages de versions concernées
- ECOSYSTEM: < 2.46.3-150400.4.97.1
Mettez à jour vers 2.46.3-150400.4.97.1
Sources originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20244117-1/
- https://bugzilla.suse.com/1232747
- https://bugzilla.suse.com/1233631
- https://bugzilla.suse.com/1233632
- https://www.suse.com/security/cve/CVE-2024-44185
- https://www.suse.com/security/cve/CVE-2024-44244
- https://www.suse.com/security/cve/CVE-2024-44296
- https://www.suse.com/security/cve/CVE-2024-44308
- https://www.suse.com/security/cve/CVE-2024-44309
- https://osv.dev/vulnerability/SUSE-SU-2024:4117-1