p PatchFirst

SUSE-SU-2024:4117-1

SUSE-SU-2024:4117-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: Update to version 2.46.3 (bsc#1232747), including fixes for: - CVE-2024-44308: Fixed arbitrary code execution by not allocating DFG register after a slow path (bsc#1233631). - CVE-2024-44309: Fixed a data isolation bypass vulnerability (bsc#1233632). - CVE-2024-44244: Processing maliciously crafted web content may lead to an unexpected process crash. - CVE-2024-44296: Processing maliciously crafted web content may prevent Content Security Policy from being enforced.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Proxy 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Manager Server 4.3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.46.3-150400.4.97.1

    Auf 2.46.3-150400.4.97.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →