SUSE-SU-2025:01746-1
SUSE-SU-2025:01746-1 · Security update for webkit2gtk3
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
This update for webkit2gtk3 fixes the following issues: Update to version 2.48.2. Security issues fixed: - CVE-2025-31205: lack of checks may lead to cross-origin data exfiltration through a malicious website (bsc#1243282). - CVE-2025-31204: improper memory handling when processing certain web content may lead to memory corruption (bsc#1243286). - CVE-2025-31206: type confusion issue when processing certain web content may lead to an unexpected crash (bsc#1243288). - CVE-2025-31215: lack of checks when processing certain web content may lead to an unexpected crash (bsc#1243289). - CVE-2025-31257: improper memory handling when processing certain web content may lead to an unexpected crash (bsc#1243596). - CVE-2025-24223: improper memory handling when processing certain web content may lead to memory corruption (bsc#1243424). Other changes and issues fixed: - Enable CSS overscroll behavior by default. - Change threaded rendering implementation to use Skia API instead of WebCore display list that is not thread safe. - Fix rendering when device scale factor change comes before the web view geometry update. - Fix network process crash on exit. - Fix the build with ENABLE_RESOURCE_USAGE=OFF. - Fix several crashes and rendering issues.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP7
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP7
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk3 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
webkit2gtk4 openSUSE:Leap 15.6
- Plages de versions concernées
- ECOSYSTEM: < 2.48.2-150600.12.40.2
Mettez à jour vers 2.48.2-150600.12.40.2
Sources originales
- https://www.suse.com/support/update/announcement/2025/suse-su-202501746-1/
- https://bugzilla.suse.com/1222905
- https://bugzilla.suse.com/1241158
- https://bugzilla.suse.com/1241160
- https://bugzilla.suse.com/1243282
- https://bugzilla.suse.com/1243286
- https://bugzilla.suse.com/1243288
- https://bugzilla.suse.com/1243289
- https://bugzilla.suse.com/1243424
- https://bugzilla.suse.com/1243596
- https://www.suse.com/security/cve/CVE-2023-42875
- https://www.suse.com/security/cve/CVE-2023-42970
- https://www.suse.com/security/cve/CVE-2024-23226
- https://www.suse.com/security/cve/CVE-2025-24223
- https://www.suse.com/security/cve/CVE-2025-31204
- https://www.suse.com/security/cve/CVE-2025-31205
- https://www.suse.com/security/cve/CVE-2025-31206
- https://www.suse.com/security/cve/CVE-2025-31215
- https://www.suse.com/security/cve/CVE-2025-31257
- https://osv.dev/vulnerability/SUSE-SU-2025:01746-1