p PatchFirst

SUSE-SU-2025:01746-1

SUSE-SU-2025:01746-1 · Security update for webkit2gtk3

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for webkit2gtk3 fixes the following issues: Update to version 2.48.2. Security issues fixed: - CVE-2025-31205: lack of checks may lead to cross-origin data exfiltration through a malicious website (bsc#1243282). - CVE-2025-31204: improper memory handling when processing certain web content may lead to memory corruption (bsc#1243286). - CVE-2025-31206: type confusion issue when processing certain web content may lead to an unexpected crash (bsc#1243288). - CVE-2025-31215: lack of checks when processing certain web content may lead to an unexpected crash (bsc#1243289). - CVE-2025-31257: improper memory handling when processing certain web content may lead to an unexpected crash (bsc#1243596). - CVE-2025-24223: improper memory handling when processing certain web content may lead to memory corruption (bsc#1243424). Other changes and issues fixed: - Enable CSS overscroll behavior by default. - Change threaded rendering implementation to use Skia API instead of WebCore display list that is not thread safe. - Fix rendering when device scale factor change comes before the web view geometry update. - Fix network process crash on exit. - Fix the build with ENABLE_RESOURCE_USAGE=OFF. - Fix several crashes and rendering issues.

Fix available

Published
Updated

Stack: system

Affected products and versions

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP7

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP7

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP7

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP7

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk3 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

  • webkit2gtk4 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.48.2-150600.12.40.2

    Update to 2.48.2-150600.12.40.2

Original sources

Check your server →