p PatchFirst

SUSE-SU-2026:1068-1

SUSE-SU-2026:1068-1 · Security update for pgvector

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

This update for pgvector fixes the following issue: Update to pgvector 0.8.2: - CVE-2026-3172: Buffer overflow in parallel HNSW index build (bsc#1258945). Changelog: * Fixed Index Searches in EXPLAIN output for Postgres 18

Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql16-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql17-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql18-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql16-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql17-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql18-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql16-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql17-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql18-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql13-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql14-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql15-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql16-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql17-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

  • postgresql18-pgvector openSUSE:Leap 15.6

    Plages de versions concernées
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Mettez à jour vers 0.8.2-150600.13.9.1

Sources originales

Vérifiez votre serveur →