p PatchFirst

SUSE-SU-2026:1068-1

SUSE-SU-2026:1068-1 · Security update for pgvector

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for pgvector fixes the following issue: Update to pgvector 0.8.2: - CVE-2026-3172: Buffer overflow in parallel HNSW index build (bsc#1258945). Changelog: * Fixed Index Searches in EXPLAIN output for Postgres 18

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql16-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql17-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql18-pgvector SUSE:Linux Enterprise Module for Server Applications 15 SP7

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql16-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql17-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql18-pgvector SUSE:Linux Enterprise Server 15 SP6-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql16-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql17-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql18-pgvector SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql13-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql14-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql15-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql16-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql17-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

  • postgresql18-pgvector openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.2-150600.13.9.1

    Auf 0.8.2-150600.13.9.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →