p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de curl

Vulnérabilité publiée pour curl au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 39

  1. CVE-2019-3823

    Moyenne · CVSS 4.3EPSS 4,12%Correctif disponible

    CVE-2019-3823

    libcurl versions from 7.34.0 to before 7.64.0 are vulnerable to a heap out-of-bounds read in the code handling the end-of-response for SMTP. If the buffer passed to `smtp_endofresp()` isn't NUL terminated and contains no character ending the parsed number, and `len` is set to 5, then the `strtol()` call reads beyond the allocated buffer. The read contents will not be returned to the caller.

    • Mettez à jour vers 7.35.0-1ubuntu2.20
    Publication Mise à jour
  2. CVE-2018-14618

    Élevée · CVSS 7.5EPSS 11,12%Correctif disponible

    CVE-2018-14618

    curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge

    • Mettez à jour vers 7.35.0-1ubuntu2.17
    Publication Mise à jour
  3. CVE-2016-8616

    Faible · CVSS 3.7EPSS 3,47%Correctif disponible

    CVE-2016-8616

    A flaw was found in curl before version 7.51.0 When re-using a connection, curl was doing case insensitive comparisons of user name and password with the existing connections. This means that if an unused connection with proper credentials exists for a protocol that has connection-scoped credentials, an attacker can cause that connection to be reused if s/he knows the case-insensitive version of the correct password.

    • Mettez à jour vers 7.35.0-1ubuntu2.10
    Publication Mise à jour
  4. CVE-2016-8624

    Moyenne · CVSS 5.3EPSS 6,25%Correctif disponible

    CVE-2016-8624

    curl before version 7.51.0 doesn't parse the authority component of the URL correctly when the host name part ends with a '#' character, and could instead be tricked into connecting to a different host. This may have security implications if you for example use an URL parser that follows the RFC to check for allowed domains before using curl to request them.

    • Mettez à jour vers 7.35.0-1ubuntu2.10
    Publication Mise à jour
  5. CVE-2016-8622

    Faible · CVSS 3.7EPSS 4,67%Correctif disponible

    CVE-2016-8622

    The URL percent-encoding decode function in libcurl before 7.51.0 is called `curl_easy_unescape`. Internally, even if this function would be made to allocate a unscape destination buffer larger than 2GB, it would return that new length in a signed 32 bit integer variable, thus the length would get either just truncated or both truncated and turned negative. That could then lead to libcurl writing outside of its heap based buffer.

    • Mettez à jour vers 7.35.0-1ubuntu2.10
    Publication Mise à jour
  6. CVE-2018-1000301

    Critique · CVSS 9.1EPSS 5,92%Correctif disponible

    CVE-2018-1000301

    curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

    • Mettez à jour vers 7.35.0-1ubuntu2.16
    Publication Mise à jour
  7. CVE-2016-9586

    Moyenne · CVSS 5.9EPSS 4,75%Correctif disponible

    CVE-2016-9586

    curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

    • Mettez à jour vers 7.35.0-1ubuntu2.11
    Publication Mise à jour
  8. CVE-2018-1000007

    Critique · CVSS 9.8EPSS 9,91%Correctif disponible

    CVE-2018-1000007

    libcurl 7.1 through 7.57.0 might accidentally leak authentication data to third parties. When asked to send custom headers in its HTTP requests, libcurl will send that set of headers first to the host in the initial URL but also, if asked to follow redirects and a 30X HTTP response code is returned, to the host mentioned in URL in the `Location:` response header value. Sending the same set of headers to subsequent hosts is in particular a problem for applications that pass on custom `Authorization:` headers, as this header often contains privacy sensitive information or data that could allow others to impersonate the libcurl-using client's re

    • Mettez à jour vers 7.35.0-1ubuntu2.14
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →