CVE-2018-1000301
CVE-2018-1000301
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.
CVSS 9.1 · Critique · EPSS 5,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
curl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.60.0-1
Mettez à jour vers 7.60.0-1
curl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.60.0-1
Mettez à jour vers 7.60.0-1
curl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.60.0-1
Mettez à jour vers 7.60.0-1
curl Ubuntu:14.04:LTS
- Versions du logiciel
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- Plages de versions concernées
- ECOSYSTEM: < 7.35.0-1ubuntu2.16
Mettez à jour vers 7.35.0-1ubuntu2.16
curl Ubuntu:16.04:LTS
- Versions du logiciel
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- Plages de versions concernées
- ECOSYSTEM: < 7.47.0-1ubuntu2.8
Mettez à jour vers 7.47.0-1ubuntu2.8
curl Ubuntu:18.04:LTS
- Versions du logiciel
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- Plages de versions concernées
- ECOSYSTEM: < 7.58.0-2ubuntu3.1
Mettez à jour vers 7.58.0-2ubuntu3.1
Sources originales
- http://www.securityfocus.com/bid/104225
- https://lists.debian.org/debian-lts-announce/2018/05/msg00010.html
- http://www.securitytracker.com/id/1040931
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- https://access.redhat.com/errata/RHSA-2018:3558
- https://curl.haxx.se/docs/adv_2018-b138.html
- https://access.redhat.com/errata/RHSA-2018:3157
- https://security.gentoo.org/glsa/201806-05
- https://www.debian.org/security/2018/dsa-4202
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- https://usn.ubuntu.com/3648-1/
- https://usn.ubuntu.com/3598-2/
- https://access.redhat.com/errata/RHBA-2019:0327
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- https://access.redhat.com/errata/RHSA-2020:0544
- https://access.redhat.com/errata/RHSA-2020:0594
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000301