p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de gnutls26

Vulnérabilité publiée pour gnutls26 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 13

  1. CVE-2016-8610

    Élevée · CVSS 7.5EPSS 39,66%Code d’exploitation publicCorrectif disponible

    CVE-2016-8610

    A denial of service flaw was found in OpenSSL 0.9.8, 1.0.1, 1.0.2 through 1.0.2h, and 1.1.0 in the way the TLS/SSL protocol defined processing of ALERT packets during a connection handshake. A remote attacker could use this flaw to make a TLS/SSL server consume an excessive amount of CPU and fail to accept connections from other clients.

    • Mettez à jour vers 2.12.23-12ubuntu2.7
    Publication Mise à jour
  2. CVE-2017-7869

    Élevée · CVSS 7.5EPSS 2,84%Correctif disponible

    CVE-2017-7869

    GnuTLS before 2017-02-20 has an out-of-bounds write caused by an integer overflow and heap-based buffer overflow related to the cdk_pkt_read function in opencdk/read-packet.c. This issue (which is a subset of the vendor's GNUTLS-SA-2017-3 report) is fixed in 3.5.10.

    • Mettez à jour vers 2.12.23-12ubuntu2.8
    Publication Mise à jour
  3. USN-2913-4

    Non évaluéeCorrectif disponible

    gnutls26 update

    USN-2913-1 removed 1024-bit RSA CA certificates from the ca-certificates package. This update adds support for alternate certificate chains to the GnuTLS package to properly handle the removal. Original advisory details: The ca-certificates package contained outdated CA certificates. This update refreshes the included certificates to those contained in the 20160104 package, including the removal of the SPI CA and CA certificates with 1024-bit RSA keys.

    • Mettez à jour vers 2.12.23-12ubuntu2.5
    Publication Mise à jour
  4. CVE-2015-7575

    Moyenne · CVSS 5.9EPSS 2,9%Correctif disponible

    CVE-2015-7575

    Mozilla Network Security Services (NSS) before 3.20.2, as used in Mozilla Firefox before 43.0.2 and Firefox ESR 38.x before 38.5.2, does not reject MD5 signatures in Server Key Exchange messages in TLS 1.2 Handshake Protocol traffic, which makes it easier for man-in-the-middle attackers to spoof servers by triggering a collision.

    • Mettez à jour vers 2.12.23-12ubuntu2.4
    Publication Mise à jour
  5. CVE-2014-3466

    Non évaluéeEPSS 11,22%Correctif disponible

    CVE-2014-3466

    Buffer overflow in the read_server_hello function in lib/gnutls_handshake.c in GnuTLS before 3.1.25, 3.2.x before 3.2.15, and 3.3.x before 3.3.4 allows remote servers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a long session id in a ServerHello message.

    • Mettez à jour vers 2.12.23-12ubuntu2.1
    Publication Mise à jour
  6. CVE-2014-1959

    Non évaluéeEPSS 3,4%Correctif disponible

    CVE-2014-1959

    lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

    • Mettez à jour vers 2.12.23-12ubuntu1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →