p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in gnutls26

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für gnutls26: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 13

  1. CVE-2016-8610

    Hoch · CVSS 7.5EPSS 39,66%Öffentlicher ExploitKorrektur verfügbar

    CVE-2016-8610

    A denial of service flaw was found in OpenSSL 0.9.8, 1.0.1, 1.0.2 through 1.0.2h, and 1.1.0 in the way the TLS/SSL protocol defined processing of ALERT packets during a connection handshake. A remote attacker could use this flaw to make a TLS/SSL server consume an excessive amount of CPU and fail to accept connections from other clients.

    • Auf 2.12.23-12ubuntu2.7 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2017-7869

    Hoch · CVSS 7.5EPSS 2,84%Korrektur verfügbar

    CVE-2017-7869

    GnuTLS before 2017-02-20 has an out-of-bounds write caused by an integer overflow and heap-based buffer overflow related to the cdk_pkt_read function in opencdk/read-packet.c. This issue (which is a subset of the vendor's GNUTLS-SA-2017-3 report) is fixed in 3.5.10.

    • Auf 2.12.23-12ubuntu2.8 aktualisieren
    Veröffentlicht Aktualisiert
  3. USN-2913-4

    Nicht bewertetKorrektur verfügbar

    gnutls26 update

    USN-2913-1 removed 1024-bit RSA CA certificates from the ca-certificates package. This update adds support for alternate certificate chains to the GnuTLS package to properly handle the removal. Original advisory details: The ca-certificates package contained outdated CA certificates. This update refreshes the included certificates to those contained in the 20160104 package, including the removal of the SPI CA and CA certificates with 1024-bit RSA keys.

    • Auf 2.12.23-12ubuntu2.5 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2015-7575

    Mittel · CVSS 5.9EPSS 2,9%Korrektur verfügbar

    CVE-2015-7575

    Mozilla Network Security Services (NSS) before 3.20.2, as used in Mozilla Firefox before 43.0.2 and Firefox ESR 38.x before 38.5.2, does not reject MD5 signatures in Server Key Exchange messages in TLS 1.2 Handshake Protocol traffic, which makes it easier for man-in-the-middle attackers to spoof servers by triggering a collision.

    • Auf 2.12.23-12ubuntu2.4 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2014-3466

    Nicht bewertetEPSS 11,22%Korrektur verfügbar

    CVE-2014-3466

    Buffer overflow in the read_server_hello function in lib/gnutls_handshake.c in GnuTLS before 3.1.25, 3.2.x before 3.2.15, and 3.3.x before 3.3.4 allows remote servers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a long session id in a ServerHello message.

    • Auf 2.12.23-12ubuntu2.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2014-1959

    Nicht bewertetEPSS 3,4%Korrektur verfügbar

    CVE-2014-1959

    lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

    • Auf 2.12.23-12ubuntu1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →