p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de anki

Vulnérabilité publiée pour anki au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 8

  1. CVE-2026-64677

    Moyenne · CVSS 5.9EPSS 1,02%Aucun correctif publié

    Anki's local HTTP server is vulnerable to directory traversal attacks

    Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.

    Publication Mise à jour
  2. CVE-2026-58266

    Moyenne · CVSS 6.5EPSS 0,22%Aucun correctif publié

    Anki: User scripts in iframes have access to the internal Anki API

    Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.

    Publication Mise à jour
  3. CVE-2026-59153

    Faible · CVSS 2.1EPSS 0,26%Aucun correctif publié

    Anki's local HTTP server does not sufficiently validate requests

    Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

    Publication Mise à jour
  4. CVE-2025-43703

    Moyenne · CVSS 6.1EPSS 0,23%Aucun correctif publié

    CVE-2025-43703

    An issue was discovered in Ankitects Anki through 25.02. A crafted shared deck can result in attacker-controlled access to the internal API (even though the attacker has no knowledge of an API key) through approaches such as scripts or the SRC attribute of an IMG element. NOTE: this issue exists because of an incomplete fix for CVE-2024-32484.

    Publication Mise à jour
  5. CVE-2024-29073

    Moyenne · CVSS 5.3EPSS 11,83%Aucun correctif publié

    CVE-2024-29073

    An vulnerability in the handling of Latex exists in Ankitects Anki 24.04. When Latex is sanitized to prevent unsafe commands, the verbatim package, which comes installed by default in many Latex distributions, has been overlooked. A specially crafted flashcard can lead to an arbitrary file read. An attacker can share a flashcard to trigger this vulnerability.

    Publication Mise à jour
  6. CVE-2024-32484

    Élevée · CVSS 7.4EPSS 21,49%Aucun correctif publié

    CVE-2024-32484

    An reflected XSS vulnerability exists in the handling of invalid paths in the Flask server in Ankitects Anki 24.04. A specially crafted flashcard can lead to JavaScript code execution and result in an arbitrary file read. An attacker can share a malicious flashcard to trigger this vulnerability.

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →