p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ruby2.3 · Page n° 2

Vulnérabilité publiée pour ruby2.3 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 41

  1. CVE-2018-1000079

    Moyenne · CVSS 5.5EPSS 2,78%Correctif disponible

    CVE-2018-1000079

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  2. CVE-2018-1000078

    Moyenne · CVSS 6.1EPSS 2,75%Correctif disponible

    CVE-2018-1000078

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  3. CVE-2018-1000077

    Moyenne · CVSS 5.3EPSS 3,6%Correctif disponible

    CVE-2018-1000077

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  4. CVE-2018-1000076

    Critique · CVSS 9.8EPSS 2,93%Correctif disponible

    CVE-2018-1000076

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  5. CVE-2018-1000075

    Élevée · CVSS 7.5EPSS 4,74%Correctif disponible

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  6. CVE-2018-1000074

    Élevée · CVSS 7.8EPSS 2,88%Correctif disponible

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  7. CVE-2018-1000073

    Élevée · CVSS 7.5EPSS 4,91%Correctif disponible

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    • Mettez à jour vers 2.3.1-2~16.04.7
    Publication Mise à jour
  8. CVE-2017-17790

    Critique · CVSS 9.8EPSS 5,91%Correctif disponible

    CVE-2017-17790

    The lazy_initialize function in lib/resolv.rb in Ruby through 2.4.3 uses Kernel#open, which might allow Command Injection attacks, as demonstrated by a Resolv::Hosts::new argument beginning with a '|' character, a different vulnerability than CVE-2017-17405. NOTE: situations with untrusted input may be highly unlikely.

    • Mettez à jour vers 2.3.1-2~16.04.5
    Publication Mise à jour
  9. CVE-2017-17405

    Élevée · CVSS 8.8EPSS 73,83%Code d’exploitation publicCorrectif disponible

    CVE-2017-17405

    Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to open a local file. If the localfile argument starts with the "|" pipe character, the command following the pipe character is executed. The default value of localfile is File.basename(remotefile), so malicious FTP servers could cause arbitrary command execution.

    • Mettez à jour vers 2.3.1-2~16.04.4
    Publication Mise à jour
  10. CVE-2017-0903

    Critique · CVSS 9.8EPSS 15,85%Correctif disponible

    CVE-2017-0903

    RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

    • Mettez à jour vers 2.3.1-2~16.04.6
    Publication Mise à jour
  11. CVE-2017-10784

    Élevée · CVSS 8.8EPSS 16,41%Correctif disponible

    CVE-2017-10784

    The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

    • Mettez à jour vers 2.3.1-2~16.04.5
    Publication Mise à jour
  12. CVE-2017-0898

    Critique · CVSS 9.1EPSS 9,72%Correctif disponible

    CVE-2017-0898

    Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

    • Mettez à jour vers 2.3.1-2~16.04.10
    Publication Mise à jour
  13. CVE-2017-14064

    Critique · CVSS 9.8EPSS 9,45%Correctif disponible

    CVE-2017-14064

    Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call. The issues lies in using strdup in ext/json/ext/generator/generator.c, which will stop after encountering a '\0' byte, returning a pointer to a string of length zero, which is not the length stored in space_len.

    • Mettez à jour vers 2.3.1-2~16.04.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →