p PatchFirst

PatchFirst · Latest vulnerabilities

ruby2.3 vulnerabilities

Vulnerabilities published for ruby2.3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 41

  1. CVE-2020-25613

    High · CVSS 7.5EPSS 3.82%Fix available

    CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Update to 2.3.1-2~ubuntu16.04.15
    Published Updated
  2. CVE-2020-10663

    High · CVSS 7.5EPSS 6.81%Fix available

    CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Update to 2.3.1-2~ubuntu16.04.15
    Published Updated
  3. CVE-2019-16254

    Medium · CVSS 5.3EPSS 4.57%Fix available

    CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Update to 2.3.1-2~ubuntu16.04.14
    Published Updated
  4. CVE-2019-16201

    High · CVSS 7.5EPSS 5.09%Fix available

    CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Update to 2.3.1-2~ubuntu16.04.14
    Published Updated
  5. CVE-2019-8324

    High · CVSS 8.8EPSS 3.22%Fix available

    CVE-2019-8324

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

    • Update to 2.3.1-2~16.04.12
    Published Updated
  6. CVE-2019-8320

    High · CVSS 7.4EPSS 4.19%Fix available

    CVE-2019-8320

    A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

    • Update to 2.3.1-2~16.04.12
    Published Updated
  7. CVE-2018-16395

    Critical · CVSS 9.8EPSS 10.71%Fix available

    CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Update to 2.3.1-2~16.04.11
    Published Updated
  8. CVE-2018-8780

    Critical · CVSS 9.1EPSS 9.98%Fix available

    CVE-2018-8780

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.

    • Update to 2.3.1-2~16.04.9
    Published Updated
  9. CVE-2018-8778

    High · CVSS 7.5EPSS 7.53%Fix available

    CVE-2018-8778

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.

    • Update to 2.3.1-2~16.04.9
    Published Updated
  10. CVE-2018-8777

    High · CVSS 7.5EPSS 4.46%Fix available

    CVE-2018-8777

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

    • Update to 2.3.1-2~16.04.10
    Published Updated
  11. CVE-2018-6914

    High · CVSS 7.5EPSS 10.16%Fix available

    CVE-2018-6914

    Directory traversal vulnerability in the Dir.mktmpdir method in the tmpdir library in Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 might allow attackers to create arbitrary directories or files via a .. (dot dot) in the prefix argument.

    • Update to 2.3.1-2~16.04.9
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →