p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ghostscript · Page n° 2

Vulnérabilité publiée pour ghostscript au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 78

  1. CVE-2020-16297

    Moyenne · CVSS 5.5EPSS 2,28%Correctif disponible

    CVE-2020-16297

    A buffer overflow vulnerability in FloydSteinbergDitheringC() in contrib/gdevbjca.c of Artifex Software GhostScript v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.13
    Publication Mise à jour
  2. CVE-2020-16296

    Moyenne · CVSS 5.5EPSS 2,05%Correctif disponible

    CVE-2020-16296

    A buffer overflow vulnerability in GetNumWrongData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.13
    Publication Mise à jour
  3. CVE-2020-16293

    Moyenne · CVSS 5.5EPSS 1,77%Correctif disponible

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.13
    Publication Mise à jour
  4. CVE-2019-14812

    Élevée · CVSS 7.3EPSS 2,47%Correctif disponible

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.11
    Publication Mise à jour
  5. CVE-2019-10216

    Élevée · CVSS 7.3EPSS 2,3%Correctif disponible

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.10
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →