p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de snapd

Vulnérabilité publiée pour snapd au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 13

  1. CVE-2020-27352

    Critique · CVSS 9.3EPSS 0,26%Correctif disponible

    CVE-2020-27352

    When generating the systemd service units for the docker snap (and other similar snaps), snapd does not specify Delegate=yes - as a result systemd will move processes from the containers created and managed by these snaps into the cgroup of the main daemon within the snap itself when reloading system units. This may grant additional privileges to a container within the snap that were not originally intended.

    • Mettez à jour vers 2.48.3+18.04
    Publication Mise à jour
  2. CVE-2023-1523

    Critique · CVSS 10EPSS 1,45%Correctif disponible

    CVE-2023-1523

    Using the TIOCLINUX ioctl request, a malicious snap could inject contents into the input of the controlling terminal which could allow it to cause arbitrary commands to be executed outside of the snap sandbox after the snap exits. Graphical terminal emulators like xterm, gnome-terminal and others are not affected - this can only be exploited when snaps are run on a virtual console.

    • Mettez à jour vers 2.58+18.04.1
    Publication Mise à jour
  3. USN-5292-4

    Non évaluéeCorrectif disponible

    snapd regression

    USN-5292-1 fixed a vulnerability in snapd. Unfortunately that update introduced a regression that could break the fish shell. This update fixes the problem. We apologize for the inconvenience. Original advisory details: James Troup discovered that snap did not properly manage the permissions for the snap directories. A local attacker could possibly use this issue to expose sensitive information. (CVE-2021-3155) Ian Johnson discovered that snapd did not properly validate content interfaces and layout paths. A local attacker could possibly use this issue to inject arbitrary AppArmor policy rules, resulting in a bypass of intended acc

    • Mettez à jour vers 2.54.3+18.04.2ubuntu0.2
    Publication Mise à jour
  4. CVE-2021-4120

    Élevée · CVSS 8.2EPSS 0,44%Correctif disponible

    snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths

    snapd 2.54.2 fails to perform sufficient validation of snap content interface and layout paths, resulting in the ability for snaps to inject arbitrary AppArmor policy rules via malformed content interface and layout declarations and hence escape strict snap confinement. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Mettez à jour vers 2.54.3+18.04
    Publication Mise à jour
  5. CVE-2021-44730

    Élevée · CVSS 7.8EPSS 0,35%Correctif disponible

    snapd could be made to escalate privileges and run programs as administrator

    snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Mettez à jour vers 2.54.3+18.04
    Publication Mise à jour
  6. CVE-2021-3155

    Faible · CVSS 3.8EPSS 0,26%Correctif disponible

    snapd created ~/snap with too-wide permissions

    snapd 2.54.2 and earlier created ~/snap directories in user home directories without specifying owner-only permissions. This could allow a local attacker to read information that should have been private. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Mettez à jour vers 2.54.3+18.04
    Publication Mise à jour
  7. CVE-2021-44731

    Élevée · CVSS 7.8EPSS 0,95%Correctif disponible

    snapd could be made to escalate privileges and run programs as administrator

    A race condition existed in the snapd 2.54.2 snap-confine binary when preparing a private mount namespace for a snap. This could allow a local attacker to gain root privileges by bind-mounting their own contents inside the snap's private mount namespace and causing snap-confine to execute arbitrary code and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Mettez à jour vers 2.54.3+18.04
    Publication Mise à jour
  8. CVE-2020-11934

    Moyenne · CVSS 5.9EPSS 0,36%Correctif disponible

    Sandbox escape vulnerability via snapctl user-open (xdg-open)

    It was discovered that snapctl user-open allowed altering the $XDG_DATA_DIRS environment variable when calling the system xdg-open. OpenURL() in usersession/userd/launcher.go would alter $XDG_DATA_DIRS to append a path to a directory controlled by the calling snap. A malicious snap could exploit this to bypass intended access restrictions to control how the host system xdg-open script opens the URL and, for example, execute a script shipped with the snap without confinement. This issue did not affect Ubuntu Core systems. Fixed in snapd versions 2.45.1ubuntu0.2, 2.45.1+18.04.2 and 2.45.1+20.04.2.

    • Mettez à jour vers 2.45.1+18.04.2
    Publication Mise à jour
  9. CVE-2019-7304

    Élevée · CVSS 8.8EPSS 60,81%Code d’exploitation publicCorrectif disponible

    Local privilege escalation via snapd socket

    Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.

    • Mettez à jour vers 2.34.2+18.04.1
    Publication Mise à jour
  10. CVE-2019-7303

    Moyenne · CVSS 5.7EPSS 3,7%Code d’exploitation publicCorrectif disponible

    Snapd seccomp filter TIOCSTI ioctl bypass

    A vulnerability in the seccomp filters of Canonical snapd before version 2.37.4 allows a strict mode snap to insert characters into a terminal on a 64-bit host. The seccomp rules were generated to match 64-bit ioctl(2) commands on a 64-bit platform; however, the Linux kernel only uses the lower 32 bits to determine which ioctl(2) commands to run. This issue affects: Canonical snapd versions prior to 2.37.4.

    • Mettez à jour vers 2.37.4+18.04.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →