p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in snapd

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für snapd: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 13

  1. CVE-2020-27352

    Kritisch · CVSS 9.3EPSS 0,26%Korrektur verfügbar

    CVE-2020-27352

    When generating the systemd service units for the docker snap (and other similar snaps), snapd does not specify Delegate=yes - as a result systemd will move processes from the containers created and managed by these snaps into the cgroup of the main daemon within the snap itself when reloading system units. This may grant additional privileges to a container within the snap that were not originally intended.

    • Auf 2.48.3+18.04 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-1523

    Kritisch · CVSS 10EPSS 1,45%Korrektur verfügbar

    CVE-2023-1523

    Using the TIOCLINUX ioctl request, a malicious snap could inject contents into the input of the controlling terminal which could allow it to cause arbitrary commands to be executed outside of the snap sandbox after the snap exits. Graphical terminal emulators like xterm, gnome-terminal and others are not affected - this can only be exploited when snaps are run on a virtual console.

    • Auf 2.58+18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. USN-5292-4

    Nicht bewertetKorrektur verfügbar

    snapd regression

    USN-5292-1 fixed a vulnerability in snapd. Unfortunately that update introduced a regression that could break the fish shell. This update fixes the problem. We apologize for the inconvenience. Original advisory details: James Troup discovered that snap did not properly manage the permissions for the snap directories. A local attacker could possibly use this issue to expose sensitive information. (CVE-2021-3155) Ian Johnson discovered that snapd did not properly validate content interfaces and layout paths. A local attacker could possibly use this issue to inject arbitrary AppArmor policy rules, resulting in a bypass of intended acc

    • Auf 2.54.3+18.04.2ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2021-4120

    Hoch · CVSS 8.2EPSS 0,44%Korrektur verfügbar

    snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths

    snapd 2.54.2 fails to perform sufficient validation of snap content interface and layout paths, resulting in the ability for snaps to inject arbitrary AppArmor policy rules via malformed content interface and layout declarations and hence escape strict snap confinement. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Auf 2.54.3+18.04 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-44730

    Hoch · CVSS 7.8EPSS 0,35%Korrektur verfügbar

    snapd could be made to escalate privileges and run programs as administrator

    snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Auf 2.54.3+18.04 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-3155

    Niedrig · CVSS 3.8EPSS 0,26%Korrektur verfügbar

    snapd created ~/snap with too-wide permissions

    snapd 2.54.2 and earlier created ~/snap directories in user home directories without specifying owner-only permissions. This could allow a local attacker to read information that should have been private. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Auf 2.54.3+18.04 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-44731

    Hoch · CVSS 7.8EPSS 0,95%Korrektur verfügbar

    snapd could be made to escalate privileges and run programs as administrator

    A race condition existed in the snapd 2.54.2 snap-confine binary when preparing a private mount namespace for a snap. This could allow a local attacker to gain root privileges by bind-mounting their own contents inside the snap's private mount namespace and causing snap-confine to execute arbitrary code and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

    • Auf 2.54.3+18.04 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2020-11934

    Mittel · CVSS 5.9EPSS 0,36%Korrektur verfügbar

    Sandbox escape vulnerability via snapctl user-open (xdg-open)

    It was discovered that snapctl user-open allowed altering the $XDG_DATA_DIRS environment variable when calling the system xdg-open. OpenURL() in usersession/userd/launcher.go would alter $XDG_DATA_DIRS to append a path to a directory controlled by the calling snap. A malicious snap could exploit this to bypass intended access restrictions to control how the host system xdg-open script opens the URL and, for example, execute a script shipped with the snap without confinement. This issue did not affect Ubuntu Core systems. Fixed in snapd versions 2.45.1ubuntu0.2, 2.45.1+18.04.2 and 2.45.1+20.04.2.

    • Auf 2.45.1+18.04.2 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2019-7304

    Hoch · CVSS 8.8EPSS 60,81%Öffentlicher ExploitKorrektur verfügbar

    Local privilege escalation via snapd socket

    Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.

    • Auf 2.34.2+18.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2019-7303

    Mittel · CVSS 5.7EPSS 3,7%Öffentlicher ExploitKorrektur verfügbar

    Snapd seccomp filter TIOCSTI ioctl bypass

    A vulnerability in the seccomp filters of Canonical snapd before version 2.37.4 allows a strict mode snap to insert characters into a terminal on a 64-bit host. The seccomp rules were generated to match 64-bit ioctl(2) commands on a 64-bit platform; however, the Linux kernel only uses the lower 32 bits to determine which ioctl(2) commands to run. This issue affects: Canonical snapd versions prior to 2.37.4.

    • Auf 2.37.4+18.04.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →