p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de containerd-app

Vulnérabilité publiée pour containerd-app au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilité : 1

  1. CVE-2024-40635

    Moyenne · CVSS 4.6EPSS 0,3%Correctif disponible

    containerd has an integer overflow in User ID handling

    containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

    • Mettez à jour vers 1.7.24-0ubuntu1~20.04.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →