p PatchFirst

PatchFirst · Latest vulnerabilities

containerd-app vulnerabilities

Vulnerabilities published for containerd-app in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2024-40635

    Medium · CVSS 4.6EPSS 0.3%Fix available

    containerd has an integer overflow in User ID handling

    containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

    • Update to 1.7.24-0ubuntu1~20.04.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →