p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de edk2

Vulnérabilité publiée pour edk2 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 19

  1. CVE-2023-45234

    Élevée · CVSS 8.3EPSS 1,19%Correctif disponible

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability when processing DNS Servers option from a DHCPv6 Advertise message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  2. CVE-2023-45233

    Élevée · CVSS 7.5EPSS 2,08%Correctif disponible

    Infinite loop in EDK II Network Package

    EDK2's Network Package is susceptible to an infinite lop vulnerability when parsing a PadN option in the Destination Options header of IPv6. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  3. CVE-2023-45232

    Élevée · CVSS 7.5EPSS 2,08%Correctif disponible

    Infinite loop in EDK II Network Package

    EDK2's Network Package is susceptible to an infinite loop vulnerability when parsing unknown options in the Destination Options header of IPv6. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  4. CVE-2023-45235

    Élevée · CVSS 8.3EPSS 1,22%Correctif disponible

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability when handling Server ID option from a DHCPv6 proxy Advertise message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  5. CVE-2023-45231

    Moyenne · CVSS 6.5EPSS 0,85%Correctif disponible

    Out-of-Bounds Read in EDK II Network Package

    EDK2's Network Package is susceptible to an out-of-bounds read vulnerability when processing  Neighbor Discovery Redirect message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  6. CVE-2023-45230

    Élevée · CVSS 8.3EPSS 1,21%Correctif disponible

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability via a long server ID option in DHCPv6 client. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  7. CVE-2022-36765

    Élevée · CVSS 7EPSS 0,29%Correctif disponible

    Integer Overflow in CreateHob

    EDK2 is susceptible to a vulnerability in the CreateHob() function, allowing a user to trigger a integer overflow to buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  8. CVE-2022-36764

    Élevée · CVSS 7EPSS 0,29%Correctif disponible

    Heap Buffer Overflow in Tcg2MeasurePeImage

    EDK2 is susceptible to a vulnerability in the Tcg2MeasurePeImage() function, allowing a user to trigger a heap buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  9. CVE-2022-36763

    Élevée · CVSS 7EPSS 0,29%Correctif disponible

    Heap Buffer Overflow in Tcg2MeasureGptTable

    EDK2 is susceptible to a vulnerability in the Tcg2MeasureGptTable() function, allowing a user to trigger a heap buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.5
    Publication Mise à jour
  10. CVE-2021-3712

    Élevée · CVSS 7.4EPSS 50,44%Correctif disponible

    Read buffer overruns processing ASN.1 strings

    ASN.1 strings are represented internally within OpenSSL as an ASN1_STRING structure which contains a buffer holding the string data and a field holding the buffer length. This contrasts with normal C strings which are repesented as a buffer for the string data which is terminated with a NUL (0) byte. Although not a strict requirement, ASN.1 strings that are parsed using OpenSSL's own "d2i" functions (and other similar parsing functions) as well as any string whose value has been set with the ASN1_STRING_set() function will additionally NUL terminate the byte array in the ASN1_STRING structure. However, it is possible for applications to direc

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.3
    Publication Mise à jour
  11. CVE-2019-11098

    Moyenne · CVSS 6.8EPSS 0,34%Correctif disponible

    CVE-2019-11098

    Insufficient input validation in MdeModulePkg in EDKII may allow an unauthenticated user to potentially enable escalation of privilege, denial of service and/or information disclosure via physical access.

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.3
    Publication Mise à jour
  12. CVE-2021-23840

    Élevée · CVSS 7.5EPSS 50,73%Correctif disponible

    Integer overflow in CipherUpdate

    Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer r

    • Mettez à jour vers 0~20191122.bd85bf54-2ubuntu3.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →