p PatchFirst

PatchFirst · Latest vulnerabilities

edk2 vulnerabilities

Vulnerabilities published for edk2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 19

  1. CVE-2023-45234

    High · CVSS 8.3EPSS 1.19%Fix available

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability when processing DNS Servers option from a DHCPv6 Advertise message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  2. CVE-2023-45233

    High · CVSS 7.5EPSS 2.08%Fix available

    Infinite loop in EDK II Network Package

    EDK2's Network Package is susceptible to an infinite lop vulnerability when parsing a PadN option in the Destination Options header of IPv6. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  3. CVE-2023-45232

    High · CVSS 7.5EPSS 2.08%Fix available

    Infinite loop in EDK II Network Package

    EDK2's Network Package is susceptible to an infinite loop vulnerability when parsing unknown options in the Destination Options header of IPv6. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  4. CVE-2023-45235

    High · CVSS 8.3EPSS 1.22%Fix available

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability when handling Server ID option from a DHCPv6 proxy Advertise message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  5. CVE-2023-45231

    Medium · CVSS 6.5EPSS 0.85%Fix available

    Out-of-Bounds Read in EDK II Network Package

    EDK2's Network Package is susceptible to an out-of-bounds read vulnerability when processing  Neighbor Discovery Redirect message. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  6. CVE-2023-45230

    High · CVSS 8.3EPSS 1.21%Fix available

    Buffer Overflow in EDK II Network Package

    EDK2's Network Package is susceptible to a buffer overflow vulnerability via a long server ID option in DHCPv6 client. This vulnerability can be exploited by an attacker to gain unauthorized access and potentially lead to a loss of Confidentiality, Integrity and/or Availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  7. CVE-2022-36765

    High · CVSS 7EPSS 0.29%Fix available

    Integer Overflow in CreateHob

    EDK2 is susceptible to a vulnerability in the CreateHob() function, allowing a user to trigger a integer overflow to buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  8. CVE-2022-36764

    High · CVSS 7EPSS 0.29%Fix available

    Heap Buffer Overflow in Tcg2MeasurePeImage

    EDK2 is susceptible to a vulnerability in the Tcg2MeasurePeImage() function, allowing a user to trigger a heap buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  9. CVE-2022-36763

    High · CVSS 7EPSS 0.29%Fix available

    Heap Buffer Overflow in Tcg2MeasureGptTable

    EDK2 is susceptible to a vulnerability in the Tcg2MeasureGptTable() function, allowing a user to trigger a heap buffer overflow via a local network. Successful exploitation of this vulnerability may result in a compromise of confidentiality, integrity, and/or availability.

    • Update to 0~20191122.bd85bf54-2ubuntu3.5
    Published Updated
  10. CVE-2021-3712

    High · CVSS 7.4EPSS 50.44%Fix available

    Read buffer overruns processing ASN.1 strings

    ASN.1 strings are represented internally within OpenSSL as an ASN1_STRING structure which contains a buffer holding the string data and a field holding the buffer length. This contrasts with normal C strings which are repesented as a buffer for the string data which is terminated with a NUL (0) byte. Although not a strict requirement, ASN.1 strings that are parsed using OpenSSL's own "d2i" functions (and other similar parsing functions) as well as any string whose value has been set with the ASN1_STRING_set() function will additionally NUL terminate the byte array in the ASN1_STRING structure. However, it is possible for applications to direc

    • Update to 0~20191122.bd85bf54-2ubuntu3.3
    Published Updated
  11. CVE-2019-11098

    Medium · CVSS 6.8EPSS 0.34%Fix available

    CVE-2019-11098

    Insufficient input validation in MdeModulePkg in EDKII may allow an unauthenticated user to potentially enable escalation of privilege, denial of service and/or information disclosure via physical access.

    • Update to 0~20191122.bd85bf54-2ubuntu3.3
    Published Updated
  12. CVE-2021-23840

    High · CVSS 7.5EPSS 50.73%Fix available

    Integer overflow in CipherUpdate

    Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer r

    • Update to 0~20191122.bd85bf54-2ubuntu3.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →