p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apr

Vulnérabilité publiée pour apr au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2023-49582

    Moyenne · CVSS 5.5EPSS 0,33%Correctif disponible

    Apache Portable Runtime (APR): Unexpected lax shared memory permissions

    Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.

    • Mettez à jour vers 1.5.2-3ubuntu0.1~esm2
    Publication Mise à jour
  2. CVE-2021-35940

    Élevée · CVSS 7.1EPSS 1,19%Correctif disponible

    Regression of CVE-2017-12613

    An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

    • Mettez à jour vers 1.5.2-3ubuntu0.1~esm1
    Publication Mise à jour
  3. CVE-2017-12613

    Élevée · CVSS 7.1EPSS 1,75%Correctif disponible

    CVE-2017-12613

    When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.

    • Mettez à jour vers 1.5.2-3ubuntu0.1~esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →