p PatchFirst

CVE-2021-35940

CVE-2021-35940 · Regression of CVE-2017-12613

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

CVSS 7.1 · Élevée · EPSS 1,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • apache portable runtime (apr)

    Versions du logiciel
    • Apache Portable Runtime 1.7.0: Concernée

    Aucun correctif publié

  • apr Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.0-7

    Mettez à jour vers 1.7.0-7

  • apr Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.0-7

    Mettez à jour vers 1.7.0-7

  • apr Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.0-7

    Mettez à jour vers 1.7.0-7

  • apr Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1

    Mettez à jour vers 1.5.0-1ubuntu0.1~esm1

  • apr Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.5.2-3
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm1

    Mettez à jour vers 1.5.2-3ubuntu0.1~esm1

  • apr Ubuntu:22.04:LTS

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.0-6ubuntu1

    Mettez à jour vers 1.7.0-6ubuntu1

Sources originales

Vérifiez votre serveur →