p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de civicrm

Vulnérabilité publiée pour civicrm au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 13

  1. CVE-2026-72558

    Élevée · CVSS 8.8EPSS 0,43%Aucun correctif publié

    CiviCRM CiviCRM - SQL Injection

    An SQL injection vulnerability in CiviCRM through 6.18.alpha1 allows authenticated staff to read the entire database via the contact search RLIKE clause. The clause concatenates a user-supplied value into the SQL query without sanitization. An attacker with staff-level access can exfiltrate all database contents including donor and member records.

    Publication Mise à jour
  2. CVE-2025-3573

    Moyenne · CVSS 5.3EPSS 0,36%Aucun correctif publié

    CVE-2025-3573

    Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

    Publication Mise à jour
  3. CVE-2023-28447

    Élevée · CVSS 7.1EPSS 1,02%Correctif disponible

    Cross site scripting vulnerability in Javascript escaping in smarty/smarty

    Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 5.33.2+dfsg1-1ubuntu1+esm1
    Publication Mise à jour
  4. CVE-2023-28115

    Critique · CVSS 9.8EPSS 2,76%Aucun correctif publié

    Snappy vulnerable to PHAR deserialization, allowing remote code execution

    Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromH

    Publication Mise à jour
  5. CVE-2022-31147

    Élevée · CVSS 7.5EPSS 2,24%Aucun correctif publié

    jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306

    The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.

    Publication Mise à jour
  6. CVE-2022-31091

    Élevée · CVSS 7.7EPSS 1,57%Aucun correctif publié

    Change in port should be considered a change in origin in Guzzle

    Guzzle, an extensible PHP HTTP client. `Authorization` and `Cookie` headers on requests are sensitive information. In affected versions on making a request which responds with a redirect to a URI with a different port, if we choose to follow it, we should remove the `Authorization` and `Cookie` headers from the request, before containing. Previously, we would only consider a change in host or scheme. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host

    Publication Mise à jour
  7. CVE-2022-31090

    Élevée · CVSS 7.7EPSS 1,92%Aucun correctif publié

    CURLOPT_HTTPAUTH option not cleared on change of origin in Guzzle

    Guzzle, an extensible PHP HTTP client. `Authorization` headers on requests are sensitive information. In affected versions when using our Curl handler, it is possible to use the `CURLOPT_HTTPAUTH` option to specify an `Authorization` header. On making a request which responds with a redirect to a URI with a different origin (change in host, scheme or port), if we choose to follow it, we should remove the `CURLOPT_HTTPAUTH` option before continuing, stopping curl from appending the `Authorization` header to the new request. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Gu

    Publication Mise à jour
  8. CVE-2021-21252

    Moyenne · CVSS 5.3EPSS 3,57%Aucun correctif publié

    Regular expression denial of service in jquery-validation

    The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

    Publication Mise à jour
  9. CVE-2018-1999022

    Critique · CVSS 9.8EPSS 2,21%Aucun correctif publié

    CVE-2018-1999022

    PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in HTML_QuickForm's getSubmitValue method, HTML_QuickForm's validate method, HTML_QuickForm_hierselect's _setOptions method, HTML_QuickForm_element's _findValue method, HTML_QuickForm_element's _prepareValue method. that can result in Possible information disclosure, possible impact on data integrity and execution of arbitrary code. This attack appear to be exploitable via A specially crafted query string could be utilised, e.g. http://www.example.com/admin/add_practice_type_id[1]=fubar%27])%20OR%20die(%27OOK!%27);%20//&mode=live. This vulnerability appears t

    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →