CVE-2023-28115
CVE-2023-28115 · Snappy vulnerable to PHAR deserialization, allowing remote code execution
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromHtml()` function, it will invoke deserialization. This vulnerability is capable of remote code execution if Snappy is used with frameworks or developer code with vulnerable POP chains. It has been fixed in version 1.4.2.
CVSS 9.8 · Critique · EPSS 2,8% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
snappy
- Versions du logiciel
- < 1.4.2: Concernée
Aucun correctif publié
civicrm Debian:11
- Versions du logiciel
- 5.33.2+dfsg1-1
- 5.50.1+dfsg1-1
- 5.50.3+dfsg1-1
- 5.52.2+dfsg1-1
- 5.53.0+dfsg1-1
- 5.68.1+dfsg1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
knplabs/knp-snappy Packagist
- Versions du logiciel
- 0.1.0
- 0.1.1
- 0.1.2
- 0.2.0
- 0.2.1
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.4
- 0.4.1
- 0.4.2
- 0.4.3
- v0.5.0
- v1.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.2.0
- v1.2.1
- v1.3.0
- v1.3.1
- v1.4.0
- v1.4.1
- Plages de versions concernées
- ECOSYSTEM: < 1.4.2
Mettez à jour vers 1.4.2
civicrm Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 4.7.1+dfsg-1
- 4.7.1+dfsg-2
- 4.7.1+dfsg-2ubuntu1
- 4.7.1+dfsg-2ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
civicrm Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4.7.23+dfsg-1ubuntu1
- 4.7.24+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
civicrm Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 5.11.0+dfsg-1
- 5.18.1+dfsg-1
- 5.20.3+dfsg-1
- 5.21.0+dfsg-1
- 5.21.1+dfsg-1
- 5.21.2+dfsg-1
- 5.21.2+dfsg-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
civicrm Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 5.33.2+dfsg1-1
- 5.33.2+dfsg1-1build1
- 5.33.2+dfsg1-1ubuntu1
- 5.33.2+dfsg1-1ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/KnpLabs/snappy/security/advisories/GHSA-gq6w-q6wh-jggc
- https://github.com/KnpLabs/snappy/pull/469
- https://github.com/KnpLabs/snappy/commit/1ee6360cbdbea5d09705909a150df7963a88efd6
- https://github.com/KnpLabs/snappy/commit/b66f79334421c26d9c244427963fa2d92980b5d3
- https://github.com/KnpLabs/snappy/blob/5126fb5b335ec929a226314d40cd8dad497c3d67/src/Knp/Snappy/AbstractGenerator.php#L670
- https://github.com/KnpLabs/snappy/releases/tag/v1.4.2
- https://nvd.nist.gov/vuln/detail/CVE-2023-28115