p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de jupyter-core

Vulnérabilité publiée pour jupyter-core au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2025-30167

    Élevée · CVSS 7.3EPSS 0,2%Aucun correctif publié

    Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

    Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by u

    Publication Mise à jour
  2. CVE-2022-39286

    Élevée · CVSS 8.8EPSS 1,45%Correctif disponible

    Execution with Unnecessary Privileges in JupyterApp

    Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

    • Mettez à jour vers 4.9.1-1ubuntu0.1~esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →