p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de node-express

Vulnérabilités publiées pour node-express au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2024-43796

    Moyenne · CVSS 5EPSS 0,49%Correctif disponible

    express vulnerable to XSS via response.redirect()

    Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

    • Mettez à jour vers 4.17.3+~4.17.13-1ubuntu0.1~esm1
    Publication Mise à jour
  2. CVE-2024-29041

    Moyenne · CVSS 6.1EPSS 0,79%Correctif disponible

    Express.js Open Redirect in malformed URLs

    Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method i

    • Mettez à jour vers 4.17.3+~4.17.13-1ubuntu0.1~esm1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →