CVE-2024-43796
CVE-2024-43796 · express vulnerable to XSS via response.redirect()
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.
CVSS 5.0 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
express
- Versions du logiciel
- < 4.20.0: Concernée
- >= 5.0.0-alpha.1, < 5.0.0: Concernée
Aucun correctif publié
node-express Debian:12
- Versions du logiciel
- 4.18.2+~4.17.14-1
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- 4.19.2+~cs8.36.26-1
- 4.21.0+~cs8.36.26-1
- 4.21.0+~cs8.36.26-2
- 4.21.2+~cs8.36.27-1
- 4.21.2+~cs8.36.27-2
- 4.21.2+~cs8.36.27-3
- 5.1.0+~cs12.3.3-1
- 5.2.1+~cs12.3.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-express Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 4.21.0+~cs8.36.26-1
Mettez à jour vers 4.21.0+~cs8.36.26-1
node-express Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 4.21.0+~cs8.36.26-1
Mettez à jour vers 4.21.0+~cs8.36.26-1
express npm
- Plages de versions concernées
- SEMVER: < 4.20.0
Mettez à jour vers 4.20.0
express npm
- Plages de versions concernées
- SEMVER: ≥ 5.0.0-alpha.1, < 5.0.0
Mettez à jour vers 5.0.0
node-express Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 4.1.1~dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
Mettez à jour vers 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
node-express Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4.1.1~dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
Mettez à jour vers 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
node-express Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 4.17.1-1
- 4.17.1-2
- Plages de versions concernées
- ECOSYSTEM: < 4.17.1-2ubuntu0.1~esm1
Mettez à jour vers 4.17.1-2ubuntu0.1~esm1
node-express Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 4.17.1-3
- 4.17.1+~cs4.17.13-1
- 4.17.2+~4.17.13-1
- 4.17.3+~4.17.13-1
- Plages de versions concernées
- ECOSYSTEM: < 4.17.3+~4.17.13-1ubuntu0.1~esm1
Mettez à jour vers 4.17.3+~4.17.13-1ubuntu0.1~esm1
node-express Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- Plages de versions concernées
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1ubuntu0.1~esm1
Mettez à jour vers 4.19.2+~cs8.36.21-1ubuntu0.1~esm1