ALPINE-CVE-2012-6708
ALPINE-CVE-2012-6708
This page contains facts from public vulnerability sources. Check the original advisory before updating.
jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.
CVSS 6.1 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 2.5.6-r0
Update to 2.5.6-r0