p PatchFirst

ALPINE-CVE-2016-5387

ALPINE-CVE-2016-5387

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Apache HTTP Server through 2.4.23 follows RFC 3875 section 4.1.18 and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue. NOTE: the vendor states "This mitigation has been assigned the identifier CVE-2016-5387"; in other words, this is not a CVE ID for a vulnerability.

CVSS 8.1 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2 Alpine:v3.4

    Affected ranges
    • ECOSYSTEM: < 2.4.23-r1

    Update to 2.4.23-r1

Original sources

Check your server →