p PatchFirst

ALPINE-CVE-2017-1000158

ALPINE-CVE-2017-1000158

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution)

CVSS 9.8 · Critical · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • python Alpine:v3.4

    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0, < 2.7.14-r0

    Update to 2.7.14-r0

  • python2 Alpine:v3.5

    Affected ranges
    • ECOSYSTEM: < 2.7.14-r0

    Update to 2.7.14-r0

  • python2 Alpine:v3.6

    Affected ranges
    • ECOSYSTEM: < 2.7.14-r0

    Update to 2.7.14-r0

Original sources

Check your server →