p PatchFirst

ALPINE-CVE-2018-1060

ALPINE-CVE-2018-1060

This page contains facts from public vulnerability sources. Check the original advisory before updating.

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in pop3lib's apop() method. An attacker could use this flaw to cause denial of service.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • python2 Alpine:v3.10

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.11

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.12

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.5

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.6

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.7

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python2 Alpine:v3.9

    Affected ranges
    • ECOSYSTEM: < 2.7.15-r0

    Update to 2.7.15-r0

  • python3 Alpine:v3.5

    Affected ranges
    • ECOSYSTEM: < 3.5.6-r0

    Update to 3.5.6-r0

  • python3 Alpine:v3.6

    Affected ranges
    • ECOSYSTEM: < 3.6.5-r0

    Update to 3.6.5-r0

  • python3 Alpine:v3.7

    Affected ranges
    • ECOSYSTEM: < 3.6.5-r0

    Update to 3.6.5-r0

  • python3 Alpine:v3.8

    Affected ranges
    • ECOSYSTEM: < 3.6.6-r0

    Update to 3.6.6-r0

Original sources

Check your server →