ALPINE-CVE-2021-22883
ALPINE-CVE-2021-22883
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 12.21.0-r0
Update to 12.21.0-r0
nodejs Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 12.21.0-r0
Update to 12.21.0-r0
nodejs Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 14.16.0-r0
Update to 14.16.0-r0