ALPINE-CVE-2021-22931
ALPINE-CVE-2021-22931
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 12.22.5-r0
Update to 12.22.5-r0
nodejs Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 12.22.5-r0
Update to 12.22.5-r0
nodejs Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 14.17.5-r0
Update to 14.17.5-r0