ALPINE-CVE-2021-23017
ALPINE-CVE-2021-23017
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.
CVSS 7.7 · High · Fix available
- Published
- Updated
Affected products and versions
nginx Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.16.1-r3
Update to 1.16.1-r3
nginx Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.16.1-r7
Update to 1.16.1-r7
nginx Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.18.0-r2
Update to 1.18.0-r2
nginx Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.18.0-r14
Update to 1.18.0-r14
nginx Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0
nginx Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 0.6.18, < 1.20.1-r0
Update to 1.20.1-r0