ALPINE-CVE-2021-33560
ALPINE-CVE-2021-33560
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libgcrypt Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.8.8-r0
Update to 1.8.8-r0
libgcrypt Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.8.8-r0
Update to 1.8.8-r0
libgcrypt Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.8.8-r0
Update to 1.8.8-r0
libgcrypt Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0
libgcrypt Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.4-r0
Update to 1.9.4-r0