ALPINE-CVE-2021-33621
ALPINE-CVE-2021-33621
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.
CVSS 8.8 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.7-r0
Update to 2.7.7-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.5-r0
Update to 3.0.5-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.3-r0
Update to 3.1.3-r0